aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 12:03:43 +0100
committerChristopher Baines <mail@cbaines.net>2018-03-18 22:16:32 +0000
commit5284372f84d7f345338d0d0c156defc1bf8ddd21 (patch)
tree90053b64be8d49bbffa3806ed045de5fca239732
parentf5de42e1fd84f504cf99fbf3d01f55b919a8156d (diff)
downloadguix-5284372f84d7f345338d0d0c156defc1bf8ddd21.tar
guix-5284372f84d7f345338d0d0c156defc1bf8ddd21.tar.gz
gnu: Add ruby-guard-compat.
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index a16eb6f428..ddff06d82c 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7654,3 +7654,28 @@ https://github.com/flavorjones/loofah-activerecord).")
(home-page
"https://github.com/guard/guard-rspec")
(license license:expat)))
+
+(define-public ruby-guard-compat
+(package
+ (name "ruby-guard-compat")
+ (version "1.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "guard-compat" version))
+ (sha256
+ (base32
+ "1zj6sr1k8w59mmi27rsii0v8xyy2rnsi09nqvwpgj1q10yq1mlis"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:test-target "spec"))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec)
+ ("ruby-rubocop" ,ruby-rubocop)))
+ (synopsis
+ "Helps creating valid Guard plugins and testing them")
+ (description
+ "Helps creating valid Guard plugins and testing them")
+ (home-page "")
+ (license license:expat)))