aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-05 20:03:12 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-18 22:16:59 +0000
commit41a67dbe81900eabb2bba70751af0bed89207e70 (patch)
tree3c71e00553e03178d79e1225ec09c363ca706980
parent2fcf4719db2e43e557ea0cac552a4e65341706ea (diff)
downloadguix-41a67dbe81900eabb2bba70751af0bed89207e70.tar
guix-41a67dbe81900eabb2bba70751af0bed89207e70.tar.gz
gnu: Add ruby-omniauth-oauth2.
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index e235adc058..ac10348505 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8104,3 +8104,28 @@ https://github.com/flavorjones/loofah-activerecord).")
"Provides swappable XML backends utilizing LibXML, Nokogiri, Ox, or REXML.")
(home-page "https://github.com/sferik/multi_xml")
(license license:expat)))
+
+(define-public ruby-omniauth-oauth2
+ (package
+ (name "ruby-omniauth-oauth2")
+ (version "1.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "omniauth-oauth2" version))
+ (sha256
+ (base32
+ "0mskwlw5ibx9mz7ywqji6mm56ikf7mglbnfc02qhg6ry527jsxdm"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-oauth2" ,ruby-oauth2)
+ ("ruby-omniauth" ,ruby-omniauth)))
+ (synopsis
+ "An abstract OAuth2 strategy for OmniAuth.")
+ (description
+ "An abstract OAuth2 strategy for OmniAuth.")
+ (home-page
+ "https://github.com/omniauth/omniauth-oauth2")
+ (license license:expat)))