aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-01-27 13:35:50 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-18 22:21:32 +0000
commit3a9653ae40ba893533b7814db94322faebbdf9b6 (patch)
tree276b91201b278fb989a6d553f20cc0be9774f87a
parentbba8aa4b2ba413ebb47f2c5afaffb1ff166a0a29 (diff)
downloadguix-3a9653ae40ba893533b7814db94322faebbdf9b6.tar
guix-3a9653ae40ba893533b7814db94322faebbdf9b6.tar.gz
gnu: Add terraform.
* gnu/packages/terraform.scm (New file). * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
-rw-r--r--gnu/packages/terraform.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/terraform.scm b/gnu/packages/terraform.scm
index 71b214ed0a..cf25f34183 100644
--- a/gnu/packages/terraform.scm
+++ b/gnu/packages/terraform.scm
@@ -24,6 +24,42 @@
#:use-module (guix build-system go)
#:use-module (gnu packages golang))
+(define-public terraform
+ (package
+ (name "terraform")
+ (version "0.11.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/terraform")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0637x7jcm62pdnivmh4rggly6dmlvdh3jpsd1z4vba15gbm203nz"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/hashicorp/terraform"
+ #:phases
+ (modify-phases %standard-phases
+ ;; I'm not sure what purpose they serve, but they are readonly, so
+ ;; they break the reset-gzip-timestamps phase.
+ (add-after 'install 'delete-test-fixtures
+ (lambda* (#:key outputs #:allow-other-keys)
+ (delete-file-recursively
+ (string-append
+ (assoc-ref outputs "out")
+ "/src/github.com/hashicorp/terraform/config/module/test-fixtures")))))))
+ (synopsis "Tool for building and changing computing infrastructure")
+ (description
+ "Terraform uses descriptions of infrastructure written in @acronym{HCL,
+Hashicorp Configuration Language} which describe graphs of resources,
+including information about dependencies. From this, Terraform can plan and
+apply changes to the described resources.
+
+Terraform uses plugins that provide intergrations to different providers.")
+ (home-page "https://www.terraform.io/")
+ (license license:mpl2.0)))
+
(define-public terraform-docs
(package
(name "terraform-docs")