aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:57:58 +0100
committerChristopher Baines <mail@cbaines.net>2018-03-18 22:16:02 +0000
commit2f605755e30b002918b8e8f7e22ec5aafea8c06e (patch)
tree7afe58821e36cef73429c0eb9f1336acea080486
parent8c5df06bd3cb823d26767fcf8ca80cfdbdeede4f (diff)
downloadguix-2f605755e30b002918b8e8f7e22ec5aafea8c06e.tar
guix-2f605755e30b002918b8e8f7e22ec5aafea8c06e.tar.gz
gnu: Add ruby-unicode-display-width.
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index be431afe5b..72fc1bde00 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7017,3 +7017,25 @@ https://github.com/flavorjones/loofah-activerecord).")
(home-page
"https://github.com/JoshCheek/thread_order")
(license license:expat)))
+
+(define-public ruby-unicode-display-width
+(package
+ (name "ruby-unicode-display-width")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "unicode-display_width" version))
+ (sha256
+ (base32
+ "194d70pfxq4d7rrk0vsk1dvj46ns2f350308khi7q5cvnmg3h1xs"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; test data not included in gem.
+ (synopsis
+ "[Unicode 1.1.0] Determines the monospace display width of a string using EastAsianWidth.txt, Unicode general category, and other data.")
+ (description
+ "[Unicode 1.1.0] Determines the monospace display width of a string using EastAsianWidth.txt, Unicode general category, and other data.")
+ (home-page
+ "http://github.com/janlelis/unicode-display_width")
+ (license license:expat)))