aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-05 11:16:12 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-18 22:16:59 +0000
commit2d32119475a27a5871eea373eca48c672ee05262 (patch)
tree2e7cd9add362660a65cad61b86907d358a617ea8
parent0bed03e678b7e60398331df7d6a854d73395f873 (diff)
downloadguix-2d32119475a27a5871eea373eca48c672ee05262.tar
guix-2d32119475a27a5871eea373eca48c672ee05262.tar.gz
gnu: Add ruby-open4.
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 17e58d729f..2634a21e50 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7895,3 +7895,24 @@ https://github.com/flavorjones/loofah-activerecord).")
(home-page
"http://github.com/technicalpickles/rspec-spies")
(license #f)))
+
+(define-public ruby-open4
+ (package
+ (name "ruby-open4")
+ (version "1.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "open4" version))
+ (sha256
+ (base32
+ "1cgls3f9dlrpil846q0w7h66vsc33jqn84nql4gcqkk221rh7px1"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (synopsis
+ "open child process with handles on pid, stdin, stdout, and stderr: manage child processes and their io handles easily.")
+ (description
+ "open child process with handles on pid, stdin, stdout, and stderr: manage child processes and their io handles easily.")
+ (home-page "https://github.com/ahoward/open4")
+ (license #f)))