aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-05 20:03:33 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-18 22:16:59 +0000
commit0b16e967a08466c59bd75071c4036ea70dea70b8 (patch)
treeb7d158b4905f553d044d83dcdb2fed18e92cc857
parent84f85c662a26ced61c51397eb5af64d66fddeca9 (diff)
downloadguix-0b16e967a08466c59bd75071c4036ea70dea70b8.tar
guix-0b16e967a08466c59bd75071c4036ea70dea70b8.tar.gz
gnu: Add ruby-oauth2.
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9e3313ac3b..fd5fce064b 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8150,3 +8150,30 @@ https://github.com/flavorjones/loofah-activerecord).")
"This package provides a pure ruby implementation of the RFC 7519 OAuth JSON Web Token (JWT) standard.")
(home-page "http://github.com/jwt/ruby-jwt")
(license license:expat)))
+
+(define-public ruby-oauth2
+ (package
+ (name "ruby-oauth2")
+ (version "1.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "oauth2" version))
+ (sha256
+ (base32
+ "094hmmfms8vpm6nwglpl7jmlv85nlfzl0kik4fizgx1rg70a6mr5"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-faraday" ,ruby-faraday)
+ ("ruby-jwt" ,ruby-jwt)
+ ("ruby-multi-json" ,ruby-multi-json)
+ ("ruby-multi-xml" ,ruby-multi-xml)
+ ("ruby-rack" ,ruby-rack)))
+ (synopsis
+ "A Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth spec.")
+ (description
+ "This package provides a Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth spec.")
+ (home-page "http://github.com/intridea/oauth2")
+ (license license:expat)))