aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-10-12 23:26:25 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-11-01 00:05:22 +0000
commitb3df4d7e573933d20fa8529ca469afafa92e93b0 (patch)
tree00aafad7704e60b9461b05d76edea55494ea2ce5
parentb58691fa73623e989a9d54cc49db5946c3b272a5 (diff)
downloadguix-b3df4d7e573933d20fa8529ca469afafa92e93b0.tar
guix-b3df4d7e573933d20fa8529ca469afafa92e93b0.tar.gz
gnu: Add speech-dispatcher.
* gnu/packages/speech.scm (speech-dispatcher): New variable.
-rw-r--r--gnu/packages/speech.scm45
1 files changed, 44 insertions, 1 deletions
diff --git a/gnu/packages/speech.scm b/gnu/packages/speech.scm
index 95c7591480..39a940dfde 100644
--- a/gnu/packages/speech.scm
+++ b/gnu/packages/speech.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 David Thompson <davet@gnu.org>
+;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22,7 +23,12 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
- #:use-module (gnu packages gcc))
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages gcc)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages pulseaudio)
+ #:use-module (gnu packages textutils))
(define-public mitlm
(package
@@ -49,3 +55,40 @@ models involving iterative parameter estimation. It achieves much of its
efficiency through the use of a compact vector representation of n-grams.")
(home-page "https://github.com/mitlm/mitlm")
(license license:expat)))
+
+(define-public speech-dispatcher
+ (package
+ (name "speech-dispatcher")
+ (version "0.8.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://devel.freebsoft.org/pub/"
+ "projects/speechd/speech-dispatcher-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "18jlxnhlahyi6njc6l6576hfvmzivjjgfjyd2n7vvrvx9inphjrb"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("dotconf" ,dotconf)
+ ("glib" ,glib)
+ ("libltdl" ,libltdl)
+ ("libsndfile" ,libsndfile)))
+ (synopsis "Common interface to speech synthesizers")
+ (description "The Speech Dispatcher project provides a high-level
+device independent layer for access to speech synthesis through a simple,
+stable and well documented interface.")
+ (home-page "https://devel.freebsoft.org/speechd")
+ ;; The software is distributed under GPL2+, but includes a number
+ ;; of files covered by other licenses.
+ (license (list license:gpl2+
+ license:fdl1.2+ ; Most files in doc/ are dual gpl2+/fdl1.2+.
+ license:lgpl2.1+
+ license:gpl2
+ (license:non-copyleft
+ ;; festival_client.{c,h} carries an expat-style license.
+ "See src/modules/festival_client.c in the distribution.")
+ license:gpl3+)))) ; doc/texinfo.tex -- with TeX exception.