aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-11-01 21:31:13 -0400
committerLeo Famulari <leo@famulari.name>2016-11-01 21:46:09 -0400
commit86c61a6bd121fca158b4ceb9f0f35e26725461ab (patch)
treec2c269d4d59c8a690d306b903226a9f916f35258
parente777d07db90a64adc4cd7c22ae921aa03bb3fc49 (diff)
downloadguix-86c61a6bd121fca158b4ceb9f0f35e26725461ab.tar
guix-86c61a6bd121fca158b4ceb9f0f35e26725461ab.tar.gz
gnu: isc-dhcp: Update to 4.3.5 [fixes CVE-2016-8864].
* gnu/packages/admin.scm (isc-dhcp): Update to 4.3.5. Update bundled 'bind' to 9.9.9-P4.
-rw-r--r--gnu/packages/admin.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index d9b08efc4c..c9563a16ed 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -470,7 +470,7 @@ connection alive.")
(bind-minor-version "9")
(bind-patch-version "9")
(bind-release-type "-P") ; for patch release, use "-P"
- (bind-release-version "3") ; for patch release, e.g. "4"
+ (bind-release-version "4") ; for patch release, e.g. "4"
(bind-version (string-append bind-major-version
"."
bind-minor-version
@@ -480,14 +480,14 @@ connection alive.")
bind-release-version)))
(package
(name "isc-dhcp")
- (version "4.3.4")
+ (version "4.3.5")
(source (origin
(method url-fetch)
(uri (string-append "http://ftp.isc.org/isc/dhcp/"
version "/dhcp-" version ".tar.gz"))
(sha256
(base32
- "0zk0imll6bfyp9p4ndn8h6s4ifijnw5bhixswifr5rnk7pp5l4gm"))))
+ "0m7rwxvpb7xrmfl9ynpckhl0hi0xgm9bq1fmbp2r68sxy5mr75gb"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-build? #f
@@ -586,7 +586,7 @@ connection alive.")
"/bind-" bind-version ".tar.gz"))
(sha256
(base32
- "1qlii6syr491yjn6kpyqknlvbsrkwlsqa0grmmfbq1g3471fyfyn"))))
+ "1qpi23lrs6jfxqx8dakbqfyg3hvrzq5ldchg6my19xcvx8515mgx"))))
;; When cross-compiling, we need the cross Coreutils and sed.
;; Otherwise just use those from %FINAL-INPUTS.