aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-10-24 16:00:31 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-10-31 10:10:26 +0000
commit58fdab1d135376b4d6426cdcbd0a88177f94aa06 (patch)
treecea972dcff018649015e42a47a2c4ab24431d201
parent6d1b3bf55b8347b5edef46924a26eb19b94be250 (diff)
downloadguix-58fdab1d135376b4d6426cdcbd0a88177f94aa06.tar
guix-58fdab1d135376b4d6426cdcbd0a88177f94aa06.tar.gz
gnu: Add ccid.
* gnu/packages/security-token.scm (ccid): New variable.
-rw-r--r--gnu/packages/security-token.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 735b2fe0ec..8f58c589d9 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Mike Gerwitz <mtg@gnu.org>
+;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,11 +26,50 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages man)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config))
+(define-public ccid
+ (package
+ (name "ccid")
+ (version "1.4.25")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://alioth.debian.org/frs/download.php/file/4187/"
+ "ccid-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "029n4lpy5nvg278s4mybisyj4lm0bcjslvwfslw6hkghw162n1kb"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags (list (string-append "--enable-usbdropdir=" %output
+ "/pcsc/drivers"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-Makefile
+ (lambda _
+ (substitute* "src/Makefile.in"
+ (("/bin/echo") (which "echo")))
+ #t)))))
+ (native-inputs
+ `(("perl" ,perl)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libusb" ,libusb)
+ ("pcsc-lite" ,pcsc-lite)))
+ (home-page "https://pcsclite.alioth.debian.org/ccid.html")
+ (synopsis "PC/SC driver for USB smart card devices")
+ (description
+ "This package provides a PC/SC IFD handler implementation for devices
+compliant with the CCID and ICCD protocols. It supports a wide range of
+readers and is needed to communicate with such devices through the
+@command{pcscd} resource manager.")
+ (license license:lgpl2.1+)))
+
(define-public libyubikey
(package
(name "libyubikey")