aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2016-10-24 17:30:50 +0200
committerFederico Beffa <beffa@fbengineering.ch>2016-10-31 16:13:31 +0100
commit505e0150dc079427eba2fa5148ab74de8784757e (patch)
tree18436b820280578ab51b847444c3539565bacb07
parent442c2c99a5d15c46551d2da6b2d23a4e39d9c4f4 (diff)
downloadguix-505e0150dc079427eba2fa5148ab74de8784757e.tar
guix-505e0150dc079427eba2fa5148ab74de8784757e.tar.gz
gnu: Add ghc-data-accessor.
* gnu/packages/haskell.scm (ghc-data-accessor): New variable.
-rw-r--r--gnu/packages/haskell.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index a933162b8b..26979f4f00 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7902,4 +7902,24 @@ monad, as well as a typeclass abstracting their common operations, and
a set of wrappers to use the hash tables in the IO monad.")
(license license:bsd-3)))
+(define-public ghc-data-accessor
+ (package
+ (name "ghc-data-accessor")
+ (version "0.2.2.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://package/data-accessor/data-accessor-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1vf2g1gac3rm32g97rl0fll51m88q7ry4m6khnl5j47qsmx24r9l"))))
+ (build-system haskell-build-system)
+ (home-page "http://www.haskell.org/haskellwiki/Record_access")
+ (synopsis
+ "Haskell utilities for accessing and manipulating fields of records")
+ (description "This package provides Haskell modules for accessing and
+manipulating fields of records.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here