aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-10-30 19:18:35 +0100
committerLeo Famulari <leo@famulari.name>2016-10-30 15:31:11 -0400
commit45b4f12727d964db1d4c753d3480a03f3ce8153d (patch)
tree551ab839898e9b710d62d26d1ff2bd9705e743f9
parent67a3b2dd4e1279e9c42d27a5d8829f13008033a4 (diff)
downloadguix-45b4f12727d964db1d4c753d3480a03f3ce8153d.tar
guix-45b4f12727d964db1d4c753d3480a03f3ce8153d.tar.gz
gnu: Add python-imagesize.
* gnu/packages/python.scm (python-imagesize, python2-imagesize): New variables. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 1292a09d32..b7c9e110c5 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11419,3 +11419,30 @@ useful as a validator for JSON data.")
(define-public python2-pyev
(package-with-python2 python-pyev))
+
+(define-public python-imagesize
+ (package
+ (name "python-imagesize")
+ (version "0.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "imagesize" version))
+ (sha256
+ (base32
+ "0qk07k0z4241lkzzjji7z4da04pcvg7bfc4xz1934zlqhwmwdcha"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/shibukawa/imagesize_py")
+ (synopsis "Gets image size of files in variaous formats in Python")
+ (description
+ "This package allows determination of image size from
+PNG, JPEG, JPEG2000 and GIF files in pure Python.")
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-imagesize))))))
+
+(define-public python2-imagesize
+ (let ((base (package-with-python2 (strip-python2-variant python-imagesize))))
+ (package
+ (inherit base)
+ (native-inputs `(("python2-setuptools" ,python2-setuptools)
+ ,@(package-native-inputs base))))))