aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2016-10-24 17:49:35 +0200
committerFederico Beffa <beffa@fbengineering.ch>2016-10-31 16:13:38 +0100
commit1a86b671cef2a65f437758f35e73f48b0ed41fb7 (patch)
treea30ee5a93e70ce7491fc7bd86db250fb62e0447d
parenta5cbef03bac9ff5f423b050b88c58c3b6cd74381 (diff)
downloadguix-1a86b671cef2a65f437758f35e73f48b0ed41fb7.tar
guix-1a86b671cef2a65f437758f35e73f48b0ed41fb7.tar.gz
gnu: Add ghc-gnuplot.
* gnu/packages/haskell.scm (ghc-gnuplot): New variable.
-rw-r--r--gnu/packages/haskell.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 2c53fdf6b2..331057a521 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7960,4 +7960,38 @@ Accessor to access state in transformers State monad.")
helper functions for Lists, Maybes, Tuples, Functions.")
(license license:bsd-3)))
+(define-public ghc-gnuplot
+ (package
+ (name "ghc-gnuplot")
+ (version "0.5.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://package/gnuplot/gnuplot-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1xz8prw9xjk0rsyrkp9bsmxykzrbhpv9qhhkdapy75mdbmgwjm7s"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-temporary" ,ghc-temporary)
+ ("ghc-utility-ht" ,ghc-utility-ht)
+ ("ghc-data-accessor-transformers" ,ghc-data-accessor-transformers)
+ ("ghc-data-accessor" ,ghc-data-accessor)
+ ("gnuplot" ,gnuplot)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'fix-path-to-gnuplot
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((gnuplot (assoc-ref inputs "gnuplot")))
+ (substitute* "os/generic/Graphics/Gnuplot/Private/OS.hs"
+ (("(gnuplotName = ).*$" all cmd)
+ (string-append cmd "\"" gnuplot "/bin/gnuplot\"")))))))))
+ (home-page "http://www.haskell.org/haskellwiki/Gnuplot")
+ (synopsis "2D and 3D plots using gnuplot")
+ (description "This package provides a Haskell module for creating 2D and
+3D plots using gnuplot.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here