aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Meyer <mark@ofosos.org>2018-01-04 18:17:38 +0100
committerLeo Famulari <leo@famulari.name>2018-01-04 13:34:58 -0500
commit72687ca5d2d8d1dd55b152823a164606fa421d9c (patch)
tree6cdcd4fd622c57dc6d961e418145e82fcb0a9d61
parentab2a4f88847eae96718137a68ba9bc4349668172 (diff)
downloadguix-72687ca5d2d8d1dd55b152823a164606fa421d9c.tar
guix-72687ca5d2d8d1dd55b152823a164606fa421d9c.tar.gz
gnu: surfraw: Point to the correct Perl executable.
* gnu/packages/web.scm (surfraw)[arguments]: Hardcode the path to Perl in a 'patch-perl' phase. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/web.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 30d5e51be9..f67f415d2f 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4765,6 +4765,13 @@ handling many of the web standards in use today.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-before 'configure 'patch-perl
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((perl (assoc-ref inputs "perl")))
+ (substitute* "surfraw.IN"
+ (("perl -e")
+ (string-append perl "/bin/perl -e")))
+ #t)))
(add-after 'install 'compress-elvi.1sr
(lambda* (#:key outputs #:allow-other-keys)
;; The manpages of the elvis are symlinks to elvi.1sr.gz