aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-01-05 14:49:13 -0500
committerKei Kebreau <kkebreau@posteo.net>2018-01-05 21:24:01 -0500
commit6885745dc149131ac806458ef0c9a10f1b235c46 (patch)
tree22d43917c62cba0b874d695b7ff6534827dbddee
parentc0c5feda4c38d6ba2189ec84b063dbfe0154794c (diff)
downloadguix-6885745dc149131ac806458ef0c9a10f1b235c46.tar
guix-6885745dc149131ac806458ef0c9a10f1b235c46.tar.gz
gnu: stellarium: Update to 0.17.0.
* gnu/packages/astronomy.scm (stellarium): Update to 0.17.0. [source]: Use new upstream URL. [arguments]: Adjust #:test-target; add #:configure-flags to locate the qtserialport header files and enable the building of tests; remove 'patch-tests' phase.
-rw-r--r--gnu/packages/astronomy.scm37
1 files changed, 19 insertions, 18 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index d21c093876..61197ccea3 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -117,15 +117,16 @@ programs for the manipulation and analysis of astronomical data.")
(define-public stellarium
(package
(name "stellarium")
- (version "0.16.0")
+ (version "0.17.0")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://sourceforge/stellarium/"
- "Stellarium-sources/"
- version "/stellarium-" version ".tar.gz"))
+ (uri (string-append "https://github.com/Stellarium/" name
+ "/releases/download/v" version
+ "/" name "-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1krxj51lix096xbz64lys166a8zdwhill5vvs7dlxdn14amc8d98"))))
+ "0d6b3fs5aify7i1lwgkcickppnj73cbh24g8qschnfs3ypdf48fc"))))
(build-system cmake-build-system)
(inputs
`(("qtbase" ,qtbase)
@@ -140,19 +141,19 @@ programs for the manipulation and analysis of astronomical data.")
("qtbase" ,qtbase) ; Qt MOC is needed at compile time
("qttools" ,qttools)))
(arguments
- `(#:test-target "tests"
- #:phases (modify-phases %standard-phases
- (add-after 'unpack 'patch-tests
- (lambda _
- (substitute* "src/tests/testStelSphereGeometry.cpp"
- (("Vec3d v[(]0[)]") "Vec3d v(0.0)"))
- #t))
- (add-before 'check 'set-offscreen-display
- (lambda _
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- (setenv "HOME" "/tmp")
- #t)))))
+ `(#:test-target "test"
+ #:configure-flags (list "-DENABLE_TESTING=1"
+ (string-append
+ "-DCMAKE_CXX_FLAGS=-isystem "
+ (assoc-ref %build-inputs "qtserialport")
+ "/include/qt5"))
+ #:phases (modify-phases %standard-phases
+ (add-before 'check 'set-offscreen-display
+ (lambda _
+ ;; make Qt render "offscreen", required for tests
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ (setenv "HOME" "/tmp")
+ #t)))))
(home-page "http://www.stellarium.org/")
(synopsis "3D sky viewer")
(description "Stellarium is a planetarium. It shows a realistic sky in