aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2018-01-02 16:53:56 +0100
committerLeo Famulari <leo@famulari.name>2018-01-04 12:44:03 -0500
commit49aebf9613e8590728fd8f8a6d6c2c84a3d0d92b (patch)
tree7b73e4cbe89e7787fa958ae6078cb56938b71df0
parent965ced9c04c6f4801bf2e3d1d64a3607ce4852b1 (diff)
downloadguix-49aebf9613e8590728fd8f8a6d6c2c84a3d0d92b.tar
guix-49aebf9613e8590728fd8f8a6d6c2c84a3d0d92b.tar.gz
gnu: Add python2-scientific.
* gnu/packages/python.scm (python2-scientific): New public variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/python.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 849fa526b1..3dde9af340 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12209,3 +12209,43 @@ and has much more to offer than Pyro or RMI. Pyro 3.x is no
longer maintained. New projects should use Pyro4 instead, which
is the new Pyro version that is actively developed.")
(license license:expat)))
+
+(define-public python2-scientific
+ (package
+ (name "python2-scientific")
+ (version "2.9.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://bitbucket.org/khinsen/"
+ "scientificpython/downloads/ScientificPython-"
+ version ".tar.gz"))
+ (file-name (string-append "ScientificPython-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0fc69zhlsn9d2jvbzyjl9ah53vj598h84nkq230c83ahfvgzx5y3"))))
+ (build-system python-build-system)
+ (inputs
+ `(("netcdf" ,netcdf)))
+ (propagated-inputs
+ `(("python-numpy" ,python2-numpy-1.8)
+ ("python-pyro", python2-pyro)))
+ (arguments
+ ;; ScientificPython is not compatible with Python 3
+ `(#:python ,python-2
+ #:tests? #f ; No test suite
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'build
+ (lambda* (#:key inputs #:allow-other-keys)
+ (zero? (system* "python" "setup.py" "build"
+ (string-append "--netcdf_prefix="
+ (assoc-ref inputs "netcdf")))))))))
+ (home-page "https://bitbucket.org/khinsen/scientificpython")
+ (synopsis "Python modules for scientific computing")
+ (description "ScientificPython is a collection of Python modules that are
+useful for scientific computing. Most modules are rather general (Geometry,
+physical units, automatic derivatives, ...) whereas others are more
+domain-specific (e.g. netCDF and PDB support). The library is currently
+not actively maintained and works only with Python 2 and NumPy < 1.9.")
+ (license license:cecill-c)))