aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-01-05 21:51:35 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-01-05 22:30:52 +0100
commit2702e12e2d29265a9b3d0c9ddbe301ce17d4eb3d (patch)
tree83de89397d8de8934fcc304731392ddc5a7b8bdd
parent23f45dd390b87096cc93891469bc11cd1470ff1a (diff)
downloadguix-2702e12e2d29265a9b3d0c9ddbe301ce17d4eb3d.tar
guix-2702e12e2d29265a9b3d0c9ddbe301ce17d4eb3d.tar.gz
gnu: Add padthv1.
* gnu/packages/music.scm (padthv1): New variable.
-rw-r--r--gnu/packages/music.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 1e04de27d9..07ea96210d 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1367,6 +1367,42 @@ effects.")
effects.")
(license license:gpl2+)))
+(define-public padthv1
+ (package
+ (name "padthv1")
+ (version "0.8.6")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "mirror://sourceforge/padthv1/padthv1/" version
+ "/padthv1-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1mikab2f9n5q1sfgnp3sbm1rf3v57k4085lsgh0a5gzga2h4hwxq"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:configure-flags
+ '("CXXFLAGS=-std=gnu++11")))
+ (inputs
+ `(("jack" ,jack-1)
+ ("lv2" ,lv2)
+ ("alsa-lib" ,alsa-lib)
+ ("non-session-manager" ,non-session-manager)
+ ("liblo" ,liblo)
+ ("fftw" ,fftw)
+ ("qtbase" ,qtbase)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("qttools" ,qttools)))
+ (home-page "http://padthv1.sourceforge.net")
+ (synopsis "Polyphonic additive synthesizer")
+ (description
+ "Padthv1 is an old-school polyphonic additive synthesizer with stereo
+effects. Padthv1 is based on the PADsynth algorithm by Paul Nasca, as a
+special variant of additive synthesis.")
+ (license license:gpl2+)))
+
(define-public amsynth
(package
(name "amsynth")