aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-01-03 10:37:07 +0100
committerRutger Helling <rhelling@mykolab.com>2018-01-03 10:40:59 +0100
commit036f35772c5ffc2ede5bf6a47422ac2c349135f4 (patch)
treeba3b1d377706e892dab5c58397141826342fe54f
parent3ee6315d8b509618d105942075c4fd0b60356d3f (diff)
downloadguix-036f35772c5ffc2ede5bf6a47422ac2c349135f4.tar
guix-036f35772c5ffc2ede5bf6a47422ac2c349135f4.tar.gz
gnu: wine64: Fix arguments.
* gnu/packages/wine.scm (wine64)[arguments]: Use new 'copy-wine32-binaries and 'copy-wine32-manpage phases instead of 'copy-wine32-files phase.
-rw-r--r--gnu/packages/wine.scm33
1 files changed, 17 insertions, 16 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index e12680da00..4ebc23f5e0 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -173,23 +173,24 @@ integrate Windows applications into your desktop.")
(string-append "libdir=" %output "/lib/wine64"))
#:phases
(modify-phases %standard-phases
- (add-after 'install 'copy-wine32-files
+ (add-after 'install 'copy-wine32-binaries
(lambda* (#:key outputs #:allow-other-keys)
- ;; Copy the 32-bit binaries needed for WoW64.
- (copy-file (string-append (assoc-ref %build-inputs "wine")
- "/bin/wine") (string-append (assoc-ref
- %outputs "out") "/bin/wine"))
- (copy-file (string-append (assoc-ref %build-inputs "wine")
- "/bin/wine-preloader") (string-append
- (assoc-ref %outputs "out")
- "/bin/wine-preloader"))
- ;; Copy the missing man file for the wine binary from wine.
- (system (string-append "gunzip < " (string-append (assoc-ref
- %build-inputs "wine")
- "/share/man/man1/wine.1.gz") "> "
- (string-append (assoc-ref %outputs "out")
- "/share/man/man1/wine.1")))
- #t))
+ (let* ((wine32 (assoc-ref %build-inputs "wine"))
+ (out (assoc-ref %outputs "out")))
+ ;; Copy the 32-bit binaries needed for WoW64.
+ (copy-file (string-append wine32 "/bin/wine")
+ (string-append out "/bin/wine"))
+ (copy-file (string-append wine32 "/bin/wine-preloader")
+ (string-append out "/bin/wine-preloader"))
+ #t)))
+ (add-after 'compress-documentation 'copy-wine32-manpage
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((wine32 (assoc-ref %build-inputs "wine"))
+ (out (assoc-ref %outputs "out")))
+ ;; Copy the missing man file for the wine binary from wine.
+ (copy-file (string-append wine32 "/share/man/man1/wine.1.gz")
+ (string-append out "/share/man/man1/wine.1.gz"))
+ #t)))
(add-after 'configure 'patch-dlopen-paths
;; Hardcode dlopened sonames to absolute paths.
(lambda _