aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-10-18 17:32:24 +0200
committerMarius Bakke <marius@gnu.org>2020-10-19 00:12:31 +0200
commitdcafa89cf0b9124d0567264eb2ef4d730b1e75bb (patch)
treee0136b14f7390f81a6be1592f97d6e67df3b6a10
parentd76b668cd6595d08761fa75d749ec943e792ea6f (diff)
downloadguix-dcafa89cf0b9124d0567264eb2ef4d730b1e75bb.tar
guix-dcafa89cf0b9124d0567264eb2ef4d730b1e75bb.tar.gz
gnu: extempore: Inline custom package variants.
Except novel ones without suitable replacements in Guix. * gnu/packages/music.scm (portmidi-for-extempore): Remove variable, and move to ... (extempore)[inputs]: ... here. * gnu/packages/llvm.scm (llvm-for-extempore): Likewise. * gnu/packages/image.scm (stb-image-for-extempore): Likewise.
-rw-r--r--gnu/packages/image.scm27
-rw-r--r--gnu/packages/llvm.scm14
-rw-r--r--gnu/packages/music.scm79
3 files changed, 53 insertions, 67 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 5f8711c869..36d7dd606f 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1530,33 +1530,6 @@ files (known as @dfn{steganography}). Neither color nor sample frequencies are
changed, making the embedding resistant against first-order statistical tests.")
(license license:gpl2+)))
-(define-public stb-image-for-extempore
- (let ((revision "1")
- (commit "152a250a702bf28951bb0220d63bc0c99830c498"))
- (package
- (name "stb-image-for-extempore")
- (version (string-append "0-" revision "." (string-take commit 9)))
- (source
- (origin (method git-fetch)
- (uri (git-reference
- (url "https://github.com/extemporelang/stb")
- (commit commit)))
- (sha256
- (base32
- "0y0aa20pj9311x2ii06zg8xs34idg14hfgldqc5ymizc6cf1qiqv"))
- (file-name (string-append name "-" version "-checkout"))))
- (build-system cmake-build-system)
- (arguments `(#:tests? #f)) ; no tests included
- ;; Extempore refuses to build on architectures other than x86_64
- (supported-systems '("x86_64-linux"))
- (home-page "https://github.com/extemporelang/stb")
- (synopsis "Image library for Extempore")
- (description
- "This package is a collection of assorted single-file libraries. Of
-all included libraries only the image loading and decoding library is
-installed as @code{stb_image}.")
- (license license:public-domain))))
-
(define-public optipng
(package
(name "optipng")
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 358fbfff0a..147247331e 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -821,20 +821,6 @@ components which highly leverage existing libraries in the larger LLVM Project."
"0846h8vn3zlc00jkmvrmy88gc6ql6014c02l4jv78fpvfigmgssg"
#:patches '("clang-3.5-libc-search-path.patch")))
-(define-public llvm-for-extempore
- (package (inherit llvm-3.8)
- (name "llvm-for-extempore")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "http://extempore.moso.com.au/extras/"
- "llvm-3.8.0.src-patched-for-extempore.tar.xz"))
- (sha256
- (base32
- "1svdl6fxn8l01ni8mpm0bd5h856ahv3h9sdzgmymr6fayckjvqzs"))))
- ;; Extempore refuses to build on architectures other than x86_64
- (supported-systems '("x86_64-linux"))))
-
(define-public libcxx
(package
(name "libcxx")
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 60a624d96d..830bc4dfbe 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -138,6 +139,7 @@
#:use-module (gnu packages rsync)
#:use-module (gnu packages sdl)
#:use-module (gnu packages sqlite)
+ #:use-module (gnu packages stb)
#:use-module (gnu packages tcl)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tex)
@@ -745,16 +747,64 @@ MusePack, Monkey's Audio, and WavPack files.")
" --mcpu=generic --attr=none")))
#t)))))
(inputs
- `(("llvm" ,llvm-for-extempore)
+ `(("llvm"
+ ,(package
+ (inherit llvm-3.8)
+ (name "llvm-for-extempore")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://extempore.moso.com.au/extras/"
+ "llvm-3.8.0.src-patched-for-extempore.tar.xz"))
+ (sha256
+ (base32
+ "1svdl6fxn8l01ni8mpm0bd5h856ahv3h9sdzgmymr6fayckjvqzs"))))))
("libffi" ,libffi)
("jack" ,jack-1)
("libsndfile" ,libsndfile)
("glfw" ,glfw)
("apr" ,apr)
- ("stb-image" ,stb-image-for-extempore)
+ ("stb-image"
+ ,(let ((revision "1")
+ (commit "152a250a702bf28951bb0220d63bc0c99830c498"))
+ (package
+ (inherit stb-image)
+ (name "stb-image-for-extempore")
+ (version (git-version "0" revision commit))
+ (source
+ (origin (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/extemporelang/stb")
+ (commit commit)))
+ (sha256
+ (base32
+ "0y0aa20pj9311x2ii06zg8xs34idg14hfgldqc5ymizc6cf1qiqv"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments `(#:tests? #f)) ;no tests included
+ (inputs '()))))
("kiss-fft" ,kiss-fft-for-extempore)
("nanovg" ,nanovg-for-extempore)
- ("portmidi" ,portmidi-for-extempore)
+ ("portmidi"
+ ,(let ((version "217")
+ (revision "0")
+ (commit "8602f548f71daf5ef638b2f7d224753400cb2158"))
+ (package
+ (inherit portmidi)
+ (name "portmidi-for-extempore")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/extemporelang/portmidi")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qidzl1s3kzhczzm96rcd2ppn27a97k2axgfh1zhvyf0s52d7m4w"))))
+ (build-system cmake-build-system)
+ (arguments `(#:tests? #f)) ;no tests
+ (native-inputs '()))))
("assimp" ,assimp)
("alsa-lib" ,alsa-lib)
("portaudio" ,portaudio)
@@ -2184,29 +2234,6 @@ main purpose is to liberate raw audio rendering from audio and MIDI drivers.")
using a system-independent interface.")
(license license:expat)))
-(define-public portmidi-for-extempore
- (let ((version "217")
- (revision "0")
- (commit "8602f548f71daf5ef638b2f7d224753400cb2158"))
- (package (inherit portmidi)
- (name "portmidi-for-extempore")
- (version (git-version version revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/extemporelang/portmidi")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1qidzl1s3kzhczzm96rcd2ppn27a97k2axgfh1zhvyf0s52d7m4w"))))
- (build-system cmake-build-system)
- (arguments `(#:tests? #f)) ; no tests
- (native-inputs '())
- ;; Extempore refuses to build on architectures other than x86_64
- (supported-systems '("x86_64-linux"))
- (home-page "https://github.com/extemporelang/portmidi/"))))
-
(define-public python-pyportmidi
(package
(name "python-pyportmidi")