aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-10-12 00:42:20 -0300
committerMarius Bakke <marius@gnu.org>2020-10-19 00:12:32 +0200
commita8eb438e78224eb8acab0b1157c9327a4fbd47a2 (patch)
tree5a162b93c962a4919fb377d029c939aa3ad13f99
parent9cd61289055cb7869df1c803c5f1490788e3fcc7 (diff)
downloadguix-a8eb438e78224eb8acab0b1157c9327a4fbd47a2.tar
guix-a8eb438e78224eb8acab0b1157c9327a4fbd47a2.tar.gz
gnu: Add passwordsafe.
* gnu/packages/gnome.scm (passwordsafe): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
-rw-r--r--gnu/packages/gnome.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d6ab0fb984..66fec1efdb 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10295,6 +10295,60 @@ photo-booth-like software, such as Cheese.")
apply fancy special effects and lets you share the fun with others.")
(license license:gpl2+)))
+(define-public passwordsafe
+ (package
+ (name "passwordsafe")
+ (version "3.99.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.gnome.org/World/PasswordSafe")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0pi2l4gwf8paxm858mxrcsk5nr0c0zw5ycax40mghndb6b1qmmhf"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prog (string-append (assoc-ref outputs "out")
+ "/bin/gnome-passwordsafe"))
+ (pylib (string-append (assoc-ref outputs "out")
+ "/lib/python"
+ ,(version-major+minor
+ (package-version python))
+ "/site-packages")))
+ (wrap-program prog
+ `("PYTHONPATH" = (,(getenv "PYTHONPATH") ,pylib))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
+ #t))))))
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils)
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk+:bin" ,gtk+ "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glib" ,glib)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gtk+" ,gtk+)
+ ("libhandy" ,libhandy-0.0)
+ ("libpwquality" ,libpwquality)
+ ("python-pygobject" ,python-pygobject)
+ ("python-pykeepass" ,python-pykeepass)))
+ (home-page "https://gitlab.gnome.org/World/PasswordSafe")
+ (synopsis "Password manager for the GNOME desktop")
+ (description
+ "Password Safe is a password manager which makes use of the KeePass v4
+format. It integrates perfectly with the GNOME desktop and provides an easy
+and uncluttered interface for the management of password databases.")
+ (license license:gpl3+)))
+
(define-public sound-juicer
(package
(name "sound-juicer")