aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-10-12 00:42:19 -0300
committerMarius Bakke <marius@gnu.org>2020-10-19 00:12:32 +0200
commit9cd61289055cb7869df1c803c5f1490788e3fcc7 (patch)
tree5eb34befb6988b7aed738899d8acdb52b4cef36f
parent68d425cda8be8356ab5e8aab54be0f19f08fedd0 (diff)
downloadguix-9cd61289055cb7869df1c803c5f1490788e3fcc7.tar
guix-9cd61289055cb7869df1c803c5f1490788e3fcc7.tar.gz
gnu: libpwquality: Enable Python binding.
* gnu/packages/password-utils.scm (libpwquality)[arguments]: Enable Python binding. [native-inputs]: Add python-wrapper. Signed-off-by: Marius Bakke <marius@gnu.org>
-rw-r--r--gnu/packages/password-utils.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 85dbeef28f..c178c2de8d 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -28,6 +28,7 @@
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Jean-Baptiste Note <jean-baptiste.note@m4x.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -381,8 +382,17 @@ them out, at the source.")
"13hw532fmzc5xjpy75d74rlfdlxf2a8ibb4hyy9c0s92wsgf0qsj"))))
(build-system gnu-build-system)
(arguments
- ;; XXX: have RUNPATH issue.
- '(#:configure-flags '("--disable-python-bindings")))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'set-LDFLAGS
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (setenv "LDFLAGS"
+ (string-append
+ "-Wl,-rpath="
+ (assoc-ref outputs "out") "/lib"))
+ #t)))))
+ (native-inputs
+ `(("python" ,python-wrapper)))
(inputs
`(("cracklib" ,cracklib)))
(synopsis "Password quality checker")