aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBonfaceKilz <bonfacemunyoki@gmail.com>2020-10-18 13:29:24 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-10-19 10:52:04 +0300
commit1f39175d1a030877b034a0ba85ef94b987b50b3e (patch)
tree08fbd48afcbea2ba1a1728200e7f6960183ce94e
parent5e7fa52841408f13636439eb94327cff1dd1bfec (diff)
downloadguix-1f39175d1a030877b034a0ba85ef94b987b50b3e.tar
guix-1f39175d1a030877b034a0ba85ef94b987b50b3e.tar.gz
gnu: Add python-parallel.
* gnu/packages/python-xyz (python-parallel): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f95f7792f7..575ce40ac8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -87,6 +87,7 @@
;;; Copyright © 2020 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
;;; Copyright © 2020 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
+;;; Copyright © 2020 Bonface Munyoki Kilyungi <bonfacemunyoki@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22493,3 +22494,33 @@ NestedText is both simple and natural. Only a small number of concepts and rule
be kept in mind when creating it. It is easily created, modified, or viewed with
a text editor and easily understood and used by both programmers and non-programmers.")
(license license:expat))) ; MIT license
+
+(define-public python-parallel
+ (package
+ (name "python-parallel")
+ (version "1.6.4.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://www.parallelpython.com/downloads/pp/pp-"
+ version ".zip"))
+ (sha256
+ (base32
+ "1mzk4yabxj6r149fswhis18hd8dnag5sj8i4wb06450zq3pi8dh7"))))
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f)) ; No test suite.
+ (home-page "https://www.parallelpython.com")
+ (synopsis "Parallel and distributed programming for Python")
+ (description "Parallel Python module (PP) provides an easy and efficient
+way to create parallel-enabled applications for SMP computers and clusters.
+PP module features cross-platform portability and dynamic load balancing.
+Thus applications written with PP will parallelize efficiently even on
+heterogeneous and multi-platform clusters (including clusters running other
+applications with variable CPU loads).")
+ (license license:bsd-3)))
+
+(define-public python2-parallel
+ (package-with-python2 python-parallel))