aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-10-12 21:53:25 -0300
committerMarius Bakke <marius@gnu.org>2020-10-19 00:12:33 +0200
commit094e234d3062e78c0a99c94a370a46581e813bc1 (patch)
tree71ad72d3965bcd687fc94753d6b6c5be5242cf72
parent2f115f56faae949a6e3ed6baee57fd4472539b72 (diff)
downloadguix-094e234d3062e78c0a99c94a370a46581e813bc1.tar
guix-094e234d3062e78c0a99c94a370a46581e813bc1.tar.gz
gnu: Add authenticator.
* gnu/packages/gnome.scm (authenticator): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
-rw-r--r--gnu/packages/gnome.scm70
1 files changed, 70 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 66fec1efdb..9da58096b8 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -74,6 +74,7 @@
(define-module (gnu packages gnome)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
+ #:use-module (gnu packages aidc)
#:use-module (gnu packages aspell)
#:use-module (gnu packages autotools)
#:use-module (gnu packages avahi)
@@ -9079,6 +9080,75 @@ specified duration and save it as a GIF encoded animated image file.")
(home-page "https://git.gnome.org/browse/byzanz")
(license license:gpl2+))))
+(define-public authenticator
+ (package
+ (name "authenticator")
+ (version "3.32.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.gnome.org/World/Authenticator")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1c4r9rnrz5gazrfg0z2rcwax4nscs7z391bcjcl74k6ln3blwzpr"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((prog (string-append (assoc-ref outputs "out")
+ "/bin/authenticator"))
+ (pylib (string-append (assoc-ref outputs "out")
+ "/lib/python"
+ ,(version-major+minor
+ (package-version python))
+ "/site-packages")))
+ (wrap-program prog
+ `("PYTHONPATH" = (,(getenv "PYTHONPATH") ,pylib))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
+ #t))))))
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils)
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk+:bin" ,gtk+ "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gtk+" ,gtk+)
+ ("libhandy" ,libhandy-0.0)
+ ("libsecret" ,libsecret)
+ ("python-beautifulsoup4" ,python-beautifulsoup4)
+ ("python-pillow" ,python-pillow)
+ ("python-pyfavicon" ,python-pyfavicon)
+ ("python-pygobject" ,python-pygobject)
+ ("python-pyotp" ,python-pyotp)
+ ("python-pyzbar" ,python-pyzbar)
+ ("yoyo-migrations" ,yoyo-migrations)
+ ("zbar" ,zbar)))
+ (home-page "https://gitlab.gnome.org/World/Authenticator/")
+ (synopsis "Two-factor authentication application built for GNOME")
+ (description
+ "Authenticator is a two-factor authentication (2FA) application built for
+the GNOME desktop environment.
+
+Features:
+
+@itemize
+@item QR code scanner
+@item Beautiful UI
+@item Huge database of more than 560 supported services
+@item Keep your PIN tokens secure by locking the application with a password
+@item Automatically fetch an image for services using their favicon
+@item The possibility to add new services
+@end itemize")
+ (license license:gpl3+)))
+
(define-public gsound
(package
(name "gsound")