aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-12-17 15:19:37 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-24 15:11:35 +0000
commitfc5fe9fdd63e3ea5d248857ad381c4b79f26e43e (patch)
treea7944e2018300ad683279dba92269c434e6e2434
parentd0f7a2ace99db7ed6d9d9ce1e264ae9c1326a496 (diff)
downloadguix-fc5fe9fdd63e3ea5d248857ad381c4b79f26e43e.tar
guix-fc5fe9fdd63e3ea5d248857ad381c4b79f26e43e.tar.gz
gnu: Add python-ujson.
* gnu/packages/python.scm (python-ujson): New variable.
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f76f59f972..3efdad30fd 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -909,6 +909,28 @@ multiple Unicode code points, e.g. \"G\" + acute-accent)
(define-public python2-uniseg
(package-with-python2 python-uniseg))
+(define-public python-ujson
+ (package
+ (name "python-ujson")
+ (version "1.35")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ujson" version))
+ (sha256
+ (base32
+ "11jz5wi7mbgqcsz52iqhpyykiaasila4lq8cmc2d54bfa3jp6q7n"))))
+ (build-system python-build-system)
+ (home-page "http://www.esn.me")
+ (synopsis
+ "Ultra fast JSON encoder and decoder for Python")
+ (description
+ "Ultra fast JSON encoder and decoder for Python")
+ (license license:bsd-3)))
+
+(define-public python2-ujson
+ (package-with-python2 python-ujson))
+
(define-public python-humanfriendly
(package
(name "python-humanfriendly")