aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-12-17 15:14:18 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-24 15:11:35 +0000
commitf4a9251ed547cb2f6e2447348d65508bd2b73812 (patch)
tree1750f962190feeec86e2c1c4134453f698833ec7
parent173b37b1d0be66340aa175f5c37e9bf08710b92f (diff)
downloadguix-f4a9251ed547cb2f6e2447348d65508bd2b73812.tar
guix-f4a9251ed547cb2f6e2447348d65508bd2b73812.tar.gz
gnu: Add python-pyemd.
* gnu/packages/python.scm (python-pyemd): New variable.
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 08207247d0..6147a13d97 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10238,6 +10238,30 @@ useful as a validator for JSON data.")
(define-public python2-validictory
(package-with-python2 python-validictory))
+(define-public python-pyemd
+ (package
+ (name "python-pyemd")
+ (version "0.4.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyemd" version))
+ (sha256
+ (base32
+ "13y06y7r1697cv4r430g45fxs40i2yk9xn0dk9nqlrpddw3a0mr4"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)))
+ (home-page "http://github.com/wmayner/pyemd")
+ (synopsis
+ "A Python wrapper for Ofir Pele and Michael Werman's implementation of the Earth Mover's Distance.")
+ (description
+ "A Python wrapper for Ofir Pele and Michael Werman's implementation of the Earth Mover's Distance.")
+ (license license:expat)))
+
+(define-public python2-pyemd
+ (package-with-python2 python-pyemd))
+
(define-public python-pyev
(package
(name "python-pyev")