aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-20 16:45:45 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-20 19:49:46 +0100
commitef8b9a771c032beff61383fa686af69cf65fffd1 (patch)
treebba31fc86236a59b0ff45f60e6498d7a9ef29952
parentd7a11f1a8d2f7083552590568819b48bb73ac161 (diff)
downloadguix-ef8b9a771c032beff61383fa686af69cf65fffd1.tar
guix-ef8b9a771c032beff61383fa686af69cf65fffd1.tar.gz
gnu: r-spams: Use predictable source URI.
* gnu/packages/statistics.scm (r-spams)[source]: Use predictable URI.
-rw-r--r--gnu/packages/statistics.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 19a05ea10b..363e6c387f 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016, 2017 Raoul Bonnal <ilpuccio.febo@gmail.com>
;;; Copyright © 2017 Kyle Meyer <kyle@kyleam.com>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3837,8 +3837,9 @@ from within R.")
(source
(origin
(method url-fetch)
- (uri (string-append "https://gforge.inria.fr/frs/download.php/36615/"
- "spams-R-v" version ".tar.gz"))
+ ;; Use the ‘Latest version’ link for a stable URI across releases.
+ (uri (string-append "https://gforge.inria.fr/frs/download.php/"
+ "latestfile/4531/spams-R-v" version ".tar.gz"))
(sha256
(base32
"13z2293jixf1r9g8dyy856xrhvpjr2ln2n9smn6644126r9hmhkx"))))
@@ -3848,7 +3849,7 @@ from within R.")
(modify-phases %standard-phases
(add-after 'unpack 'chdir
(lambda _ (chdir "spams") #t))
- ;; Don't tune for the building machine
+ ;; Don't tune for the building machine.
(add-after 'chdir 'no-mtune
(lambda _
(substitute* "src/Makevars"