aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-12-17 15:50:25 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-24 15:11:35 +0000
commitee57e40de19eba8d311086c04a09b5565e7b02cc (patch)
tree98138cdc086dbb7f18b49abb9b5fc6eaf6aef78f
parent06030db5a60814d8139992166ff1c62f413c6fbe (diff)
downloadguix-ee57e40de19eba8d311086c04a09b5565e7b02cc.tar
guix-ee57e40de19eba8d311086c04a09b5565e7b02cc.tar.gz
gnu: Add python-plac.
* gnu/packages/.scm (python-plac): New variable.
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5f985d3607..7cb714c7ab 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7744,6 +7744,28 @@ library as well as on the command line.")
(define-public python2-rsa
(package-with-python2 python-rsa))
+(define-public python-plac
+ (package
+ (name "python-plac")
+ (version "0.9.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "plac" version))
+ (sha256
+ (base32
+ "16zqpalx4i1n1hrcvaj8sdixapy2g76fc13bbahz0xc106d72gxs"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/micheles/plac")
+ (synopsis
+ "The smartest command line arguments parser in the world")
+ (description
+ "The smartest command line arguments parser in the world")
+ (license license:bsd-3)))
+
+(define-public python2-plac
+ (package-with-python2 python-plac))
+
(define-public python-pluggy
(package
(name "python-pluggy")