aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-12-17 19:17:17 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-24 15:12:08 +0000
commitdb780f751e894101879087154bd397865f180d7e (patch)
treeaddc25f02a2040d2627d290de637b197aff3840f
parent501ad8b56d506de73cf0fe40282fcb85eb63e683 (diff)
downloadguix-db780f751e894101879087154bd397865f180d7e.tar
guix-db780f751e894101879087154bd397865f180d7e.tar.gz
gnu: Add python-sybil.
* gnu/packages/check.scm (python-sybil): New variable.
-rw-r--r--gnu/packages/check.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index b279646402..7dfa8a0b54 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1055,6 +1055,37 @@ python-fixtures package instead.")
(define-public python2-fixtures-bootstrap
(package-with-python2 python-fixtures-bootstrap))
+(define-public python-sybil
+ (package
+ (name "python-sybil")
+ (version "1.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sybil" version))
+ (sha256
+ (base32
+ "1wghhsp70kbz0g0j62zmq35srymd9w950s9f0v4vx37nxw4xvmsv"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (zero? (system* "python" "-m" "pytest")))))))
+ (propagated-inputs
+ `(("python-nose" ,python-nose)
+ ("python-pytest" ,python-pytest-3.0)))
+ (home-page "https://github.com/cjw296/sybil")
+ (synopsis
+ "Automated testing for the examples in your documentation.")
+ (description
+ "Automated testing for the examples in your documentation.")
+ (license license:expat)))
+
+(define-public python2-sybil
+ (package-with-python2 python-sybil))
+
(define-public python-fixtures
(package
(inherit python-fixtures-bootstrap)