aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-12-17 15:16:20 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-24 15:11:35 +0000
commitd0f7a2ace99db7ed6d9d9ce1e264ae9c1326a496 (patch)
tree96f8a813168bac0e05bbffa2fc2a5a7ef504a178
parentf4a9251ed547cb2f6e2447348d65508bd2b73812 (diff)
downloadguix-d0f7a2ace99db7ed6d9d9ce1e264ae9c1326a496.tar
guix-d0f7a2ace99db7ed6d9d9ce1e264ae9c1326a496.tar.gz
gnu: Add python-pyphen.
* gnu/packages/python.scm (python-pyphen): New variable.
-rw-r--r--gnu/packages/python.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 6147a13d97..f76f59f972 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3295,6 +3295,27 @@ that client code uses to construct the grammar directly in Python code.")
(define-public python2-pyparsing
(package-with-python2 python-pyparsing))
+(define-public python-pyphen
+ (package
+ (name "python-pyphen")
+ (version "0.9.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Pyphen" version))
+ (sha256
+ (base32
+ "1mqb5jrigxipxzp1d8nbwkq0cfjw77pnn6hc4mp1yd2mn059mymb"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/Kozea/Pyphen")
+ (synopsis "Pure Python module to hyphenate text")
+ (description
+ "Pure Python module to hyphenate text")
+ (license #f)))
+
+(define-public python2-pyphen
+ (package-with-python2 python-pyphen))
+
(define-public python-numpydoc
(package
(name "python-numpydoc")