aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-12-17 16:13:07 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-24 15:13:27 +0000
commitcd053f26fabb5166e29a4113e1785be20892c25d (patch)
treecee5c0eb3398a08d9e69d40f0624770ca6d77231
parent58ab00dc0a6607eeec40bba9c4635741327c5fbc (diff)
downloadguix-cd053f26fabb5166e29a4113e1785be20892c25d.tar
guix-cd053f26fabb5166e29a4113e1785be20892c25d.tar.gz
gnu: Add python-gensim.
* gnu/packages/python.scm (python-gensim): New variable.
-rw-r--r--gnu/packages/machine-learning.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 3d2545b390..84b9aa099c 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -48,6 +48,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-web)
#:use-module (gnu packages statistics)
#:use-module (gnu packages swig)
#:use-module (gnu packages xml)
@@ -749,3 +750,43 @@ mining and data analysis.")
(define-public python2-keras
(package-with-python2 python-keras))
+
+(define-public python-gensim
+ (package
+ (name "python-gensim")
+ (version "3.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "gensim" version))
+ (sha256
+ (base32
+ "0l16gqg8mvp10msl3aps2dqr3493aj42lakw0vsc82h2dwph29s8"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("python-annoy" ,python-annoy)
+ ("python-annoy" ,python-annoy)
+ ("python-keras" ,python-keras)
+ ("python-morfessor" ,python-morfessor)
+ ("python-pyemd" ,python-pyemd)
+ ("python-pyro4" ,python-pyro4)
+ ("python-scikit-learn" ,python-scikit-learn)
+ ("python-sphinx" ,python-sphinx)
+ ("python-smart-open" ,python-smart-open)
+ ("python-sphinxcontrib-napoleon"
+ ,python-sphinxcontrib-napoleon)
+ ("python-pattern" ,python-pattern)
+ ;("python-tensorflow" ,python-tensorflow)
+ ;("python-testfixtures" ,python-testfixtures)
+ ))
+ (home-page "http://radimrehurek.com/gensim")
+ (synopsis
+ "Python framework for fast Vector Space Modelling")
+ (description
+ "Python framework for fast Vector Space Modelling")
+ (license #f)))
+
+(define-public python2-gensim
+ (package-with-python2 python-gensim))