aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-12-17 15:57:20 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-24 15:11:35 +0000
commita803586ee43205c5f0f669421e14d714bf6f9190 (patch)
tree04035c2411285258885ff086e5027999d3302dd5
parent1c9f865803f105d2ea69def3ac3759293c765230 (diff)
downloadguix-a803586ee43205c5f0f669421e14d714bf6f9190.tar
guix-a803586ee43205c5f0f669421e14d714bf6f9190.tar.gz
gnu: Add python-annoy.
* gnu/packages/python.scm (python-annoy): New variable.
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 37df1c4ed5..5d7e028c3d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8129,6 +8129,30 @@ fast xml and html manipulation.")
(define-public python2-pyquery
(package-with-python2 python-pyquery))
+(define-public python-annoy
+ (package
+ (name "python-annoy")
+ (version "1.9.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "annoy" version))
+ (sha256
+ (base32
+ "12kk52wid493ys28l5l8zllh3jcbg8yivpq95iy68fhpd9gkpmld"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-nose" ,python-nose)))
+ (home-page "https://github.com/spotify/annoy")
+ (synopsis
+ "Approximate Nearest Neighbors in C++/Python optimized for memory usage and loading/saving to disk.")
+ (description
+ "Approximate Nearest Neighbors in C++/Python optimized for memory usage and loading/saving to disk.")
+ (license #f)))
+
+(define-public python2-annoy
+ (package-with-python2 python-annoy))
+
(define-public python-anyjson
(package
(name "python-anyjson")