aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-12-17 15:54:43 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-24 15:11:35 +0000
commit80a78f290d7ebc26ff250dae6f5eab7ffe7d2408 (patch)
tree5b0d0866a25fed244eaae5797d5456186798735f
parent6cfed19f032091371b8c3f0b3c754d07658c6a55 (diff)
downloadguix-80a78f290d7ebc26ff250dae6f5eab7ffe7d2408.tar
guix-80a78f290d7ebc26ff250dae6f5eab7ffe7d2408.tar.gz
gnu: Add python-spacy-models-en-core-web-sm.
* gnu/packages/python.scm (python-spacy-models-en-core-web-sm): New variable.
-rw-r--r--gnu/packages/python.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index fff871d92d..f98985e883 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2463,6 +2463,43 @@ reStructuredText.")
(define-public python2-spacy
(package-with-python2 python-spacy))
+(define-public python-spacy-models-en-core-web-sm
+ (package
+ (name "python-spacy-models-en-core-web-sm")
+ (version "2.0.0a7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/explosion/spacy-models/releases/download/"
+ "en_core_web_sm-" version "/en_core_web_sm-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1mhnzvmm2v24ibr7v7qagvh8d10pg7cjvg7chxijrc618732zck3"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'add-symlink
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (source (string-append
+ out "/lib/python3.5/site-packages/en_core_web_sm"))
+ (target (string-append
+ out "/lib/python3.5/site-packages/spacy/data/en")))
+ (mkdir-p (dirname target))
+ (symlink source target)))))))
+ (home-page "https://spacy.io")
+ (synopsis
+ "Industrial-strength Natural Language Processing (NLP) with Python and Cython")
+ (description
+ "Industrial-strength Natural Language Processing (NLP) with Python and Cython")
+ (license license:expat)))
+
+(define-public python2-spacy-models-en-core-web-sm
+ (package-with-python2 python-spacy-models-en-core-web-sm))
+
(define-public python-sphinxcontrib-websupport
(package
(name "python-sphinxcontrib-websupport")