aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-12-17 15:53:09 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-24 15:11:35 +0000
commit6cfed19f032091371b8c3f0b3c754d07658c6a55 (patch)
tree15f63001f190bca0c68eb1371a06ed44e8391f12
parentee57e40de19eba8d311086c04a09b5565e7b02cc (diff)
downloadguix-6cfed19f032091371b8c3f0b3c754d07658c6a55.tar
guix-6cfed19f032091371b8c3f0b3c754d07658c6a55.tar.gz
gnu: Add python-spacy.
* gnu/packages/python.scm (python-spacy): New variable.
-rw-r--r--gnu/packages/python.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7cb714c7ab..fff871d92d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2412,6 +2412,57 @@ reStructuredText.")
(define-public python2-pygments
(package-with-python2 python-pygments))
+(define-public python-spacy
+ (package
+ (name "python-spacy")
+ (version "2.0.0a17")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/explosion/spaCy/archive/v" version ".tar.gz"))
+ (sha256
+ (base32
+ "1dq389f7qpni9lw5vksiizb542012ql6g7v1wk7xlg6jc2yxl2la"))))
+ ;; (source
+ ;; (origin
+ ;; (method url-fetch)
+ ;; (uri (pypi-uri "spacy" version))
+ ;; (sha256
+ ;; (base32
+ ;; "19mhg40zkpc153rsn0y2p8hzxfk6hv6cr7ds6a08mmazr8nxdmc9"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'patch
+ (lambda _
+ (substitute* "spacy/util.py"
+ (("from_disk\\(model\\_path")
+ "from_disk(model_path, disable=(\"meta.json\",)")))))))
+ (inputs
+ `(("python-cython" ,python-cython)))
+ (propagated-inputs
+ `(("python-ujson" ,python-ujson)
+ ("python-numpy" ,python-numpy)
+ ("python-regex" ,python-regex)
+ ("python-requests" ,python-requests)
+ ("python-cymem" ,python-cymem)
+ ("python-preshed" ,python-preshed)
+ ("python-murmurhash" ,python-murmurhash)
+ ("python-thinc" ,python-thinc)
+ ("python-plac" ,python-plac)))
+ (home-page "https://spacy.io")
+ (synopsis
+ "Industrial-strength Natural Language Processing (NLP) with Python and Cython")
+ (description
+ "Industrial-strength Natural Language Processing (NLP) with Python and Cython")
+ (license license:expat)))
+
+(define-public python2-spacy
+ (package-with-python2 python-spacy))
+
(define-public python-sphinxcontrib-websupport
(package
(name "python-sphinxcontrib-websupport")