aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-12-17 16:03:20 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-24 15:11:35 +0000
commit6bbeab0e076566a1ff39e08b5763526db8490c61 (patch)
tree2cfdf197423f2687e1164cff366c0d870937a957
parent8bddd0cb453cdd6597e813b2439c639a85864b4f (diff)
downloadguix-6bbeab0e076566a1ff39e08b5763526db8490c61.tar
guix-6bbeab0e076566a1ff39e08b5763526db8490c61.tar.gz
gnu: Add python-serpent.
* gnu/packages/python.scm (python-serpent): New variable.
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index faf6211a86..96d94554d7 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12858,6 +12858,28 @@ belong to tagged versions.")
(define-public python2-setuptools-scm-git-archive
(package-with-python2 python-setuptools-scm-git-archive))
+(define-public python-serpent
+ (package
+ (name "python-serpent")
+ (version "1.23")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "serpent" version))
+ (sha256
+ (base32
+ "199vhl8rmsijzmdr1pwfnvnrdbkxda69k5p3kx6rgf34i0ywx044"))))
+ (build-system python-build-system)
+ (home-page "")
+ (synopsis
+ "Serialization based on ast.literal_eval")
+ (description
+ "Serialization based on ast.literal_eval")
+ (license license:expat)))
+
+(define-public python2-serpent
+ (package-with-python2 python-serpent))
+
(define-public python-pyclipper
(package
(name "python-pyclipper")