aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-12-17 14:37:22 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-24 15:11:35 +0000
commit5b704c0c2eb9e58ffba31defa0617896fbaf5374 (patch)
tree67b1ed3c331d136be1edf7a3401485fb7ada468e
parentbba66e7a600b35159d20e41df7c18fc1ec764dd9 (diff)
downloadguix-5b704c0c2eb9e58ffba31defa0617896fbaf5374.tar
guix-5b704c0c2eb9e58ffba31defa0617896fbaf5374.tar.gz
gnu: Add python-cachetools.
* gnu/packages/python.scm (python-cachetools): New variable.
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3811233272..f694de6749 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -555,6 +555,28 @@ and function call return values in a human-readable way.")
(define-public python2-shapely
(package-with-python2 python-shapely))
+(define-public python-cachetools
+ (package
+ (name "python-cachetools")
+ (version "2.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cachetools" version))
+ (sha256
+ (base32
+ "0pdw2fr29pxlyn1g5fhdrrqbpn0iw062nv716ngdqvdx7hnizq7d"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/tkem/cachetools")
+ (synopsis "Extensible memoizing collections and decorators for Python")
+ (description
+ "The cachetools module provides various memoizing collections and
+decorators for Python.")
+ (license license:expat)))
+
+(define-public python2-cachetools
+ (package-with-python2 python-cachetools))
+
(define-public python-clyent
(package
(name "python-clyent")