aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-12-17 16:11:36 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-24 15:13:27 +0000
commit58ab00dc0a6607eeec40bba9c4635741327c5fbc (patch)
treece0e0a17fdd5913254c9b617584d36579d968ab6
parentd1458e631a79b85c3aebaac9d4093268be922d8c (diff)
downloadguix-58ab00dc0a6607eeec40bba9c4635741327c5fbc.tar
guix-58ab00dc0a6607eeec40bba9c4635741327c5fbc.tar.gz
gnu: Add python-smart-open.
* gnu/packages/python.scm (python-smart-open): New variable.
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9c675f928d..8248f61138 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12548,6 +12548,33 @@ many of the popular cloud service providers using a unified API.")
(define-public python2-apache-libcloud
(package-with-python2 python-apache-libcloud))
+(define-public python-smart-open
+(package
+ (name "python-smart-open")
+ (version "1.5.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "smart_open" version))
+ (sha256
+ (base32
+ "0m5j71f7f36s17v4mwv0bxg4azknvcy82rbjp28b4vifrjd6dm7s"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("python-boto" ,python-boto)))
+ (home-page
+ "https://github.com/piskvorky/smart_open")
+ (synopsis
+ "Utils for streaming large files (S3, HDFS, gzip, bz2...)")
+ (description
+ "Utils for streaming large files (S3, HDFS, gzip, bz2...)")
+ (license license:expat)))
+
+(define-public python2-smart-open
+ (package-with-python2 python-smart-open))
+
(define-public python-smmap2
(package
(name "python-smmap2")