aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-12-17 16:07:11 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-24 15:11:36 +0000
commit501ad8b56d506de73cf0fe40282fcb85eb63e683 (patch)
treed0847caddd03a7502041274ae97d600af300fa9d
parent371ef56e847cf70fff66953258f06e82385f405f (diff)
downloadguix-501ad8b56d506de73cf0fe40282fcb85eb63e683.tar
guix-501ad8b56d506de73cf0fe40282fcb85eb63e683.tar.gz
gnu: Add python-sphinxcontrib-napoelon.
* gnu/packages/python.scm (python-sphinxcontrib-napoelon): New variable.
-rw-r--r--gnu/packages/python.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a8154e18c3..21d1ccc993 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8527,6 +8527,41 @@ programmatically interfacing with your system's $EDITOR.")
(define-public python2-editor
(package-with-python2 python-editor))
+(define-public python-sphinxcontrib-napoleon
+ (package
+ (name "python-sphinxcontrib-napoleon")
+ (version "0.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sphinxcontrib-napoleon" version))
+ (sha256
+ (base32
+ "1gfnsj257n2i2raaj5q918x83lxnzfzifv5dvzgi97v2i2c7fjv1"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (propagated-inputs
+ `(("python-pockets" ,python-pockets)
+ ("python-sphinx" ,python-sphinx)
+ ("python-six" ,python-six)))
+ (home-page
+ "https://sphinxcontrib-napoleon.readthedocs.io")
+ (synopsis "Sphinx \"napoleon\" extension.")
+ (description "Sphinx \"napoleon\" extension.")
+ (license license:bsd-3)))
+
+(define-public python2-sphinxcontrib-napoleon
+ (let ((python2-sphinxcontrib-napoleon
+ (package-with-python2 python-sphinxcontrib-napoleon)))
+ (package (inherit python2-sphinxcontrib-napoleon)
+ (propagated-inputs
+ `(("python2-selectors34" ,python2-selectors34)
+ ,@(package-propagated-inputs
+ python2-sphinxcontrib-napoleon))))))
+
(define-public python-sphinxcontrib-programoutput
(package
(name "python-sphinxcontrib-programoutput")