aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-12-17 19:39:09 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-24 15:11:36 +0000
commit371ef56e847cf70fff66953258f06e82385f405f (patch)
tree6774882a333a4bfe6e3667398dde87a829ab6fd7
parentaa88594ebc43019165ef2e45941a2948bbe60670 (diff)
downloadguix-371ef56e847cf70fff66953258f06e82385f405f.tar
guix-371ef56e847cf70fff66953258f06e82385f405f.tar.gz
gnu: Add python2-selectors34.
* gnu/packages/python.scm (python2-selectors34): New variable.
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4f52e76b0d..a8154e18c3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -827,6 +827,29 @@ API for locking files.")
(define-public python2-lockfile
(package-with-python2 python-lockfile))
+(define-public python2-selectors34
+ (package
+ (name "python2-selectors34")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "selectors34" version))
+ (sha256
+ (base32
+ "0725hqbbfjw9aicmfydz21ya29wsz1rph9iz4fsnz9zq6xihdx89"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2))
+ (propagated-inputs `(("python2-six" ,python2-six)))
+ (home-page
+ "https://github.com/berkerpeksag/selectors34")
+ (synopsis
+ "Backport of the selectors module from Python 3.4.")
+ (description
+ "Backport of the selectors module from Python 3.4.")
+ (license #f)))
+
(define-public python-setuptools
(package
(name "python-setuptools")