aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-12-17 15:11:03 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-24 15:11:35 +0000
commit36861b59fddc342af7ee4706645ffea1a96595f2 (patch)
tree9745fe1e01c613b6fde02e7a6a5335e821193489
parent7e93bb49f6ac3abc22a8acef4f3b419409e11416 (diff)
downloadguix-36861b59fddc342af7ee4706645ffea1a96595f2.tar
guix-36861b59fddc342af7ee4706645ffea1a96595f2.tar.gz
gnu: Add python-ftfy.
* gnu/packages/python.scm (python-ftfy): New variable.
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 33b397e78d..d27f4b4e76 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2617,6 +2617,33 @@ which can produce feeds in RSS 2.0, RSS 0.91, and Atom formats.")
(define-public python2-feedgenerator
(package-with-python2 python-feedgenerator))
+(define-public python-ftfy
+ (package
+ (name "python-ftfy")
+ (version "5.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ftfy" version))
+ (sha256
+ (base32
+ "0y4yqagn0n64n6bfwcsi8m0d17j99x70i9x0v31awwjzmlprm8k7"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("python-wcwidth" ,python-wcwidth)))
+ (home-page
+ "http://github.com/LuminosoInsight/python-ftfy")
+ (synopsis
+ "Fixes some problems with Unicode text after the fact")
+ (description
+ "Fixes some problems with Unicode text after the fact")
+ (license license:expat)))
+
+(define-public python2-ftfy
+ (package-with-python2 python-ftfy))
+
(define-public python-blinker
(package
(name "python-blinker")