aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-12-17 15:55:53 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-24 15:11:35 +0000
commit1c9f865803f105d2ea69def3ac3759293c765230 (patch)
treeca1560785f518f1c916e80f35c3f3222bb2305ae
parent80a78f290d7ebc26ff250dae6f5eab7ffe7d2408 (diff)
downloadguix-1c9f865803f105d2ea69def3ac3759293c765230.tar
guix-1c9f865803f105d2ea69def3ac3759293c765230.tar.gz
gnu: Add python-textacy.
* gnu/packages/python.scm (python-textacy): New variable.
-rw-r--r--gnu/packages/python.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f98985e883..37df1c4ed5 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7357,6 +7357,47 @@ the standard library.")
(define-public python2-contextlib2
(package-with-python2 python-contextlib2))
+(define-public python-textacy
+ (package
+ (name "python-textacy")
+ (version "0.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "textacy" version))
+ (sha256
+ (base32
+ "04wf3a7zgzz83nmgkh488wkl50zm9yfdpv3sl12sm2zj685plqcz"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("python-cachetools" ,python-cachetools)
+ ("python-cytoolz" ,python-cytoolz)
+ ("python-ftfy" ,python-ftfy)
+ ("python-ijson" ,python-ijson)
+ ("python-levenshtein" ,python-levenshtein)
+ ("python-networkx" ,python-networkx)
+ ("python-numpy" ,python-numpy)
+ ("python-pyemd" ,python-pyemd)
+ ("python-pyphen" ,python-pyphen)
+ ("python-requests" ,python-requests)
+ ("python-scikit-learn" ,python-scikit-learn)
+ ("python-scipy" ,python-scipy)
+ ("python-spacy" ,python-spacy)
+ ("python-tqdm" ,python-tqdm)
+ ("python-unidecode" ,python-unidecode)))
+ (home-page
+ "https://github.com/chartbeat-labs/textacy")
+ (synopsis
+ "Higher-level text processing, built on spaCy")
+ (description
+ "Higher-level text processing, built on spaCy")
+ (license #f)))
+
+(define-public python2-textacy
+ (package-with-python2 python-textacy))
+
(define-public python-texttable
(package
(name "python-texttable")