aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-12-17 16:08:59 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-24 15:13:27 +0000
commit0c5e2f9a19434d38f4113e2deaa0c963af0c9ca6 (patch)
treee244610dfc441a1cbc0f152b8f2eec0f0c82be79
parentdb780f751e894101879087154bd397865f180d7e (diff)
downloadguix-0c5e2f9a19434d38f4113e2deaa0c963af0c9ca6.tar
guix-0c5e2f9a19434d38f4113e2deaa0c963af0c9ca6.tar.gz
gnu: Add python-textfixtures.
* gnu/packages/python.scm (python-textfixtures): New variable.
-rw-r--r--gnu/packages/check.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 7dfa8a0b54..34d47b6193 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -51,6 +51,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages llvm)
#:use-module (gnu packages golang)
+ #:use-module (gnu packages django)
#:use-module (gnu packages python)
#:use-module (gnu packages python-web)
#:use-module (gnu packages time)
@@ -834,6 +835,47 @@ subprocess and see the output as well as any file modifications.")
(define-public python2-scripttest
(package-with-python2 python-scripttest))
+(define-public python-testfixtures
+ (package
+ (name "python-testfixtures")
+ (version "5.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "testfixtures" version))
+ (sha256
+ (base32
+ "0a47b32sjrw3hkmdb92b1h28n2dg7j4jwsly41w244xp22adw2k7"))))
+ (build-system python-build-system)
+ (arguments
+ '(;; TODO: The tests fail oddly.
+ ;;
+ ;; /gnu/store/cs2vv5dnwv729xqk8grffd6l1i3gmf9r-python-pytest-3.0.7/lib/python3.5/site-packages/_pytest/config.py:325: in _getconftestmodules
+ ;; return self._path2confmods[path]
+ ;; E KeyError: local('/tmp/guix-build-python-testfixtures-5.3.1.drv-0/testfixtures-5.3.1/build/lib/testfixtures/tests')
+ #:tests? #f
+ #:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (or (not tests?)
+ (zero? (system* "python" "-m" "pytest"))))))))
+ (native-inputs
+ `(("python-django" ,python-django)
+ ("python-mock" ,python-mock)
+ ("python-pytest-django" ,python-pytest-django)
+ ("python-sybil" ,python-sybil)
+ ("python-zope-component" ,python-zope-component)))
+ (home-page
+ "https://github.com/Simplistix/testfixtures")
+ (synopsis
+ "A collection of helpers and mock objects for unit tests and doc tests.")
+ (description
+ "A collection of helpers and mock objects for unit tests and doc tests.")
+ (license license:expat)))
+
+(define-public python2-testfixtures
+ (package-with-python2 python-testfixtures))
+
(define-public python-testtools-bootstrap
(package
(name "python-testtools-bootstrap")