aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-12-17 15:48:41 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-24 15:11:35 +0000
commit06030db5a60814d8139992166ff1c62f413c6fbe (patch)
tree40d5a70b5c1aa9fb76caf8403da695d717f19d94
parent34c6b80835a8474daac8392064a65a34ec59c94a (diff)
downloadguix-06030db5a60814d8139992166ff1c62f413c6fbe.tar
guix-06030db5a60814d8139992166ff1c62f413c6fbe.tar.gz
gnu: Add python-thinc.
* gnu/packages/machine-learning.scm (python-thinc, python2-thinc): New variable.
-rw-r--r--gnu/packages/machine-learning.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 12384a1031..2376cf8b2c 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -155,6 +155,43 @@ classification.")
`(("python" ,python)))
(synopsis "Python bindings of libSVM")))
+(define-public python-thinc
+ (package
+ (name "python-thinc")
+ (version "6.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "thinc" version))
+ (sha256
+ (base32
+ "094j7zphpbb1i2qqi4z965q08w08vs08n42d1gykq21nkg45iy48"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("python-msgpack" ,python-msgpack)
+ ("python-msgpack-numpy" ,python-msgpack-numpy)
+ ("python-numpy", python-numpy)
+ ("python-wrapt" ,python-wrapt)
+ ("python-murmurhash" ,python-murmurhash)
+ ("python-cymem" ,python-cymem)
+ ("python-preshed" ,python-preshed)
+ ("python-tqdm" ,python-tqdm)
+ ("python-cytoolz" ,python-cytoolz)
+ ("python-plac" ,python-plac)
+ ("python-dill" ,python-dill)
+ ("python-termcolor" ,python-termcolor)
+ ("python-pathlib" ,python-pathlib)))
+ (home-page "https://github.com/explosion/thinc")
+ (synopsis "Practical Machine Learning for NLP")
+ (description
+ "Practical Machine Learning for NLP")
+ (license license:expat)))
+
+(define-public python2-thinc
+ (package-with-python2 python-thinc))
+
(define-public ghmm
;; The latest release candidate is several years and a couple of fixes have
;; been published since. This is why we download the sources from the SVN