aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-10-28 11:26:55 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-10-28 11:26:55 +0100
commitfbf024c5b0c4cdfe756ff6de94c4151e18f6c55e (patch)
tree0a260fc483e3b1ecd2a1c18415b1315dc5cbf6be
parent0dc301838f4ae3be172a595c1f92279a2d40c714 (diff)
downloadguix-fbf024c5b0c4cdfe756ff6de94c4151e18f6c55e.tar
guix-fbf024c5b0c4cdfe756ff6de94c4151e18f6c55e.tar.gz
gnu: Add emacs-frame-local.
* gnu/packages/emacs-xyz.scm (emacs-frame-local): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 019b2c670b..aa978029a4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19437,6 +19437,34 @@ functions to ensure they are called with the right arguments during testing.")
too ambiguous and navigation in the result buffer.")
(license license:gpl3+))))
+(define-public emacs-frame-local
+ ;; There is no release yet. Version is extracted from the main
+ ;; file.
+ (let ((version "0.0.1")
+ (revision "0")
+ (commit "7ee1106c3bcd4022f48421f8cb1ef4f995da816e"))
+ (package
+ (name "emacs-frame-local")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sebastiencs/frame-local")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zfxsxdh3bd3fd566zl0byp13p5b8f4cgkwl637imvarvahczigp"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/sebastiencs/frame-local")
+ (synopsis "Access variables local to an Emacs frame")
+ (description
+ "This packages allows setting and accessing variables local to
+an Emacs frame. Note that the variables created with this package do
+not have any relation with variables defined by @code{defvar},
+@code{defconst}, etc.")
+ (license license:gpl3+))))
+
(define-public emacs-frame-purpose
(package
(name "emacs-frame-purpose")