aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-10-27 13:11:15 +0100
committerMathieu Othacehe <othacehe@gnu.org>2020-10-27 13:11:15 +0100
commita01f32924423c45a0ffa50f6c1727be2a25ef75c (patch)
tree53744b1fd5c4bcb55e007d808276ab38426421ad
parent559c134b0ece171fcd39b31e5444b955deefcc8e (diff)
downloadguix-a01f32924423c45a0ffa50f6c1727be2a25ef75c.tar
guix-a01f32924423c45a0ffa50f6c1727be2a25ef75c.tar.gz
gnu: nvi: Fix cross-compilation.
* gnu/packages/nvi.scm (nvi)[arguments]: Add "vi_cv_sprintf_count=yes" to configure flags when cross-compiling. Also add 'fix-configure phase. [native-inputs]: Add "automake" that is required by the new phase.
-rw-r--r--gnu/packages/nvi.scm34
1 files changed, 29 insertions, 5 deletions
diff --git a/gnu/packages/nvi.scm b/gnu/packages/nvi.scm
index c34b1cad72..eea6093cec 100644
--- a/gnu/packages/nvi.scm
+++ b/gnu/packages/nvi.scm
@@ -64,17 +64,41 @@
(build-system gnu-build-system)
(arguments
`(#:out-of-source? #t
- #:configure-flags '("--enable-widechar")))
+ #:configure-flags
+ '("--enable-widechar"
+ ,@(if (%current-target-system)
+ '("vi_cv_sprintf_count=yes")
+ '()))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'fix-configure
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ ;; Replace outdated config.sub and config.guess:
+ (with-directory-excursion "dist"
+ (for-each (lambda (file)
+ (chmod file #o755)
+ (install-file
+ (string-append
+ (assoc-ref
+ (or native-inputs inputs) "automake")
+ "/share/automake-"
+ ,(version-major+minor
+ (package-version automake))
+ "/" file) "."))
+ '("config.sub")))
+ #t)))))
(inputs
`(("bdb" ,bdb)
("ncurses" ,ncurses)))
+ (native-inputs
+ `(("automake" ,automake))) ;Up to date 'config.guess' and 'config.sub'.
(synopsis "The Berkeley Vi Editor")
(description
"Vi is the original screen based text editor for Unix systems. It is
considered the standard text editor, and is available on almost all Unix
-systems. Nvi is intended as a \"bug-for-bug compatible\" clone of the original
-BSD vi editor. As such, it doesn't have a lot of snazzy features as do some
-of the other vi clones such as elvis and vim. However, if all you want is vi,
-this is the one to get.")
+systems. Nvi is intended as a \"bug-for-bug compatible\" clone of the
+original BSD vi editor. As such, it doesn't have a lot of snazzy features as
+do some of the other vi clones such as elvis and vim. However, if all you
+want is vi, this is the one to get.")
(home-page "https://sites.google.com/a/bostic.com/keithbostic/vi")
(license bsd-3)))