aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-10-27 18:06:38 -0400
committerLeo Famulari <leo@famulari.name>2020-10-27 18:18:17 -0400
commit6bfbdc949c6d463eb96db4555e30037ce4769ba6 (patch)
tree960c235a40d37abefe5991a0ff6adbf233d32f20
parent4c3196c752d37be643a8eb4fd00eadb8e5b9dbf9 (diff)
downloadguix-6bfbdc949c6d463eb96db4555e30037ce4769ba6.tar
guix-6bfbdc949c6d463eb96db4555e30037ce4769ba6.tar.gz
gnu: khal: Skip the test suite.
* gnu/packages/calendar.scm (khal)[arguments]: Disable the test suite. Remove the custom 'check' phase. [native-inputs]: Remove python-pytest, python-pytest-cov, python-freezegun, tzdata-for-tests, and vdirsyncer.
-rw-r--r--gnu/packages/calendar.scm21
1 files changed, 4 insertions, 17 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index dabf8bfb15..607d2d8328 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -177,7 +177,8 @@ data units.")
"11qhrga44knlnp88py9p547d4nr5kn041d2nszwa3dqw7mf22ks9"))))
(build-system python-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
+ `(#:tests? #f ; The test suite is unreliable. See <https://bugs.gnu.org/44197>
+ #:phases (modify-phases %standard-phases
;; Building the manpage requires khal to be installed.
(add-after 'install 'manpage
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -187,23 +188,9 @@ data units.")
(install-file
"doc/build/man/khal.1"
(string-append (assoc-ref outputs "out") "/share/man/man1"))
- #t))
- (replace 'check
- (lambda* (#:key inputs tests? #:allow-other-keys)
- (if tests?
- (begin
- ;; The tests require us to choose a timezone.
- (setenv "TZ" "UTC")
- ;; The disabled test expects /dev/tty.
- (invoke "pytest" "tests" "-k" "not test_import_from_stdin"))))))))
+ #t)))))
(native-inputs
- `(("python-pytest" ,python-pytest)
- ("python-pytest-cov" ,python-pytest-cov)
- ("python-setuptools-scm" ,python-setuptools-scm)
- ;; Required for tests
- ("python-freezegun" ,python-freezegun)
- ("tzdata" ,tzdata-for-tests)
- ("vdirsyncer" ,vdirsyncer)
+ `(("python-setuptools-scm" ,python-setuptools-scm)
;; Required to build manpage
("python-sphinxcontrib-newsfeed" ,python-sphinxcontrib-newsfeed)
("python-sphinx" ,python-sphinx)))