aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-10-27 12:00:07 +0100
committerMathieu Othacehe <othacehe@gnu.org>2020-10-27 12:02:31 +0100
commit559c134b0ece171fcd39b31e5444b955deefcc8e (patch)
tree2d375045020b0b83c903fd30ddcc8905569bddc1
parente03920223004fd60879ada9874aed21f38dc1799 (diff)
downloadguix-559c134b0ece171fcd39b31e5444b955deefcc8e.tar
guix-559c134b0ece171fcd39b31e5444b955deefcc8e.tar.gz
gnu: acl: Fix cross-compilation.
This is a follow-up of 6693eac6eb9e13852f2b4156f1e9ebcd70ec43b6. * gnu/packages/acl.scm (acl): Disable tests when cross-compiling.
-rw-r--r--gnu/packages/acl.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/acl.scm b/gnu/packages/acl.scm
index 4e90703d81..be4b079b04 100644
--- a/gnu/packages/acl.scm
+++ b/gnu/packages/acl.scm
@@ -51,7 +51,8 @@
`(#:modules ((ice-9 ftw)
,@%gnu-build-system-modules)
#:configure-flags '("--disable-static")
- #:tests? ,(not (hurd-target?))
+ #:tests? ,(not (or (%current-target-system)
+ (hurd-target?)))
#:phases
(modify-phases %standard-phases
;; XXX After repacking the sources the timestamps are reset to the