aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-10-28 11:42:15 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-10-28 11:42:15 +0100
commit044dcdb5b09d77ad780b19d534cfd9fc8c25e6a7 (patch)
tree0a7479b8d7371afecb4f532bef46e039b0b11bdb
parentfbf024c5b0c4cdfe756ff6de94c4151e18f6c55e (diff)
downloadguix-044dcdb5b09d77ad780b19d534cfd9fc8c25e6a7.tar
guix-044dcdb5b09d77ad780b19d534cfd9fc8c25e6a7.tar.gz
gnu: Add emacs-company-box.
* gnu/packages/emacs-xyz.scm (emacs-company-box): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index aa978029a4..40e4c6367e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4907,6 +4907,41 @@ front-ends. Company comes with many back-ends, e.g., @code{company-elisp}.
These are distributed in separate files and can be used individually.")
(license license:gpl3+)))
+(define-public emacs-company-box
+ ;; There is no release yet. Version is extracted from the main
+ ;; file.
+ (let ((version "0.0.1")
+ (revision "0")
+ (commit "be37a9a30dc112ab172af21af694e2cb04a74f85"))
+ (package
+ (name "emacs-company-box")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sebastiencs/company-box")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13fgmdy51gqdwijqfvb784pirx4lgva0y7ysi0c3fcx8f82cdj59"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-company" ,emacs-company)
+ ("emacs-dash" ,emacs-dash)
+ ("emacs-frame-local" ,emacs-frame-local)))
+ (home-page "https://github.com/sebastiencs/company-box")
+ (synopsis "Company front-end with icons")
+ (description
+ "Company box is a Company front-end. It supports different
+colors for different backends, associates icons to functions,
+variables... and their backends, and displays candidate's
+documentation. It is not limited by the current window size or
+buffer's text properties.
+
+This package is not compatible with a TTY.")
+ (license license:gpl3+))))
+
(define-public emacs-company-posframe
(let ((version "0.1.0")
(revision "1")