aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-08-03 22:46:17 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-10-27 20:14:05 +0100
commit00fad32a2c0c28150901505f7d77272cc44fce84 (patch)
tree27761f3a1c75c378e0342e88c4dc5edec2ff7ce2
parentb4941e30e3a01a11bf0eac6fd1c68aa33b06aaf8 (diff)
downloadguix-00fad32a2c0c28150901505f7d77272cc44fce84.tar
guix-00fad32a2c0c28150901505f7d77272cc44fce84.tar.gz
gnu: Add kuserfeedback.
* gnu/packages/kde.scm (kuserfeedback): New variable.
-rw-r--r--gnu/packages/kde.scm48
1 files changed, 47 insertions, 1 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index f38f64253b..2751e6d04d 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
-;;; Copyright © 2018, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2018, 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
@@ -40,12 +40,14 @@
#:use-module (gnu packages algebra)
#:use-module (gnu packages apr)
#:use-module (gnu packages audio)
+ #:use-module (gnu packages bison)
#:use-module (gnu packages boost)
#:use-module (gnu packages code)
#:use-module (gnu packages cpp)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages flex)
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
@@ -790,3 +792,47 @@ services such as printers which advertise themselves with DNSSD (called Avahi
or Bonjour by other projects).")
(license ;; GPL for programs, LGPL for libraries, FDL for documentation
(list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+
+
+(define-public kuserfeedback
+ ;; FIXME: Try to reduce data collection and ensure transmission i disabled by default.
+ ;; FIXME: Check https://www.reddit.com/r/kde/comments/f7ojg9 for insights
+ (package
+ (name "kuserfeedback")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/kuserfeedback/"
+ "/kuserfeedback-" version ".tar.xz"))
+ (sha256
+ (base32 "1dwx9fscnfp3zsxdir774skn8xvad2dvscnaaw3ji6mrnkmm6bss"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("qttools" ,qttools)
+ ;; For optional component "Survey target expression parser"
+ ("bison" ,bison)
+ ("flex" ,flex)
+ ;; For syntax checking and unit tests of PHP server code
+ ;;("php" ,php)
+ ;;("phpunit" ,phpunit)
+ ))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("qtcharts" ,qtcharts)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtsvg" ,qtsvg)))
+ (arguments
+ `(#:tests? #f)) ;; 4/17 fail
+ (home-page "https://api.kde.org/frameworks/kuserfeedback/html/")
+ (synopsis "Framework for collecting feedback from application users via
+telemetry and targeted surveys")
+ (description "This framework consists of the following components:
+@itermize
+@item Libraries for use in applications.
+@item QML bindings for the above.
+@item A server application.
+@item A management and analytics application.
+@end itemize")
+ (license license:expat)))