aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-11-23 12:38:13 -0300
committerLeo Famulari <leo@famulari.name>2020-11-25 18:38:00 -0500
commit8cd10a76b886cc92ef20562eeebba53f401e3b35 (patch)
tree38dd0643e0ccd2ff1524433f8e9e979671219769
parent402ebffe195890c9826cfa7519034dd12a48ae6a (diff)
downloadguix-8cd10a76b886cc92ef20562eeebba53f401e3b35.tar
guix-8cd10a76b886cc92ef20562eeebba53f401e3b35.tar.gz
gnu: Add python-pynndescent.
* gnu/packages/machine-learning.scm (python-pynndescent): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/machine-learning.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 34b522c99b..2ad148b48e 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -65,6 +65,7 @@
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages image)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages llvm)
#:use-module (gnu packages maths)
#:use-module (gnu packages mpi)
#:use-module (gnu packages ocaml)
@@ -869,6 +870,32 @@ data analysis.")
(base32
"08zbzi8yx5wdlxfx9jap61vg1malc9ajf576w7a0liv6jvvrxlpj")))))))
+(define-public python-pynndescent
+ (package
+ (name "python-pynndescent")
+ (version "0.4.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pynndescent" version))
+ (sha256
+ (base32 "0li1fclif50v6xrq7wh3lif9vv5jpj7xhrb0z6g89wwjnp9b9833"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (propagated-inputs
+ `(("python-joblib" ,python-joblib)
+ ("python-llvmlite" ,python-llvmlite)
+ ("python-numba" ,python-numba)
+ ("python-scikit-learn" ,python-scikit-learn)
+ ("python-scipy" ,python-scipy)))
+ (home-page "https://github.com/lmcinnes/pynndescent")
+ (synopsis "Nearest neighbor descent for approximate nearest neighbors")
+ (description
+ "PyNNDescent provides a Python implementation of Nearest Neighbor Descent
+for k-neighbor-graph construction and approximate nearest neighbor search.")
+ (license license:bsd-2)))
+
(define-public python-scikit-rebate
(package
(name "python-scikit-rebate")