aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2020-11-26 10:08:54 +0100
committerJelle Licht <jlicht@fsfe.org>2020-11-26 10:12:05 +0100
commit3a0cb77df6532b85ea5d9e149ecfc3a7540b0620 (patch)
tree26ec3029297e4fd4e491ed2b19a5ee254dbd3659
parent446ec88a4021e1fadc34a6e4c29d6c8105c841b2 (diff)
downloadguix-3a0cb77df6532b85ea5d9e149ecfc3a7540b0620.tar
guix-3a0cb77df6532b85ea5d9e149ecfc3a7540b0620.tar.gz
gnu: emacs-closql: Update to 1.0.4.
* gnu/packages/emacs-xyz.scm (emacs-closql): Update to 1.0.4.
-rw-r--r--gnu/packages/emacs-xyz.scm44
1 files changed, 21 insertions, 23 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 907ff200e0..6865346cf0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14540,33 +14540,31 @@ official @command{sqlite3} executable to access SQL database.")
(license license:gpl3+)))
(define-public emacs-closql
- ;; Take a commit newer than 1.0.0 release because of Emacs upgrade to 26.3.
- (let ((commit "70b98dbae53611d10a461d9b4a6f71086910dcef"))
- (package
- (name "emacs-closql")
- (version (git-version "1.0.0" "1" commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/emacscollective/closql")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1wvhrihg663f61yzc7f0vha2abjdnlwbk0gjcwakdfk1bhwf5ikh"))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-emacsql" ,emacs-emacsql)))
- (home-page "https://github.com/emacscollective/closql")
- (synopsis "Store EIEIO objects using EmacSQL")
- (description
- "This package stores uniform EIEIO objects in an EmacSQL
+ (package
+ (name "emacs-closql")
+ (version "1.0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacscollective/closql")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "06j0sc6dx8f34wc8i7dzkp8jwvwnrpnl8i93vpc1qw0ih0jwa2zh"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-emacsql" ,emacs-emacsql)))
+ (home-page "https://github.com/emacscollective/closql")
+ (synopsis "Store EIEIO objects using EmacSQL")
+ (description
+ "This package stores uniform EIEIO objects in an EmacSQL
database. SQLite is used as backend. This library imposes some restrictions
on what kind of objects can be stored; it isn't intended to store arbitrary
objects. All objects have to share a common superclass and subclasses cannot
add any additional instance slots.")
- (license license:gpl3))))
+ (license license:gpl3)))
(define-public emacs-epkg
(package