aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-26 15:20:39 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-26 20:44:39 +0100
commit2aa8e8476dfa7ef0552f5d66fc2887c6e65051f1 (patch)
tree2a6772a7c0e914f768dd3533a00e2d29455e6ae9
parent0dca2e630f50056f0092bd1df32f714528ae1594 (diff)
downloadguix-2aa8e8476dfa7ef0552f5d66fc2887c6e65051f1.tar
guix-2aa8e8476dfa7ef0552f5d66fc2887c6e65051f1.tar.gz
gnu: djvulibre: Update to 3.5.28.
* gnu/packages/djvu.scm (djvulibre): Update to 3.5.28. [native-inputs]: Add autoconf, automake, and libtool to bootstrap. [inputs]: Add zlib. [arguments]: Rename 'reproducible phase to 'make-reproducible and run it after bootstrapping.
-rw-r--r--gnu/packages/djvu.scm40
1 files changed, 24 insertions, 16 deletions
diff --git a/gnu/packages/djvu.scm b/gnu/packages/djvu.scm
index e68231a3c5..9f49bbce81 100644
--- a/gnu/packages/djvu.scm
+++ b/gnu/packages/djvu.scm
@@ -50,26 +50,34 @@
(define-public djvulibre
(package
(name "djvulibre")
- (version "3.5.27")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/djvu/DjVuLibre/"
- version "/djvulibre-" version ".tar.gz"))
- (sha256
- (base32
- "0psh3zl9dj4n4r3lx25390nx34xz0bg0ql48zdskhq354ljni5p6"))))
+ (version "3.5.28")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/djvu/DjVuLibre/"
+ (string-replace-substring version "." ",")
+ "/djvulibre-" version ".tar.gz"))
+ (sha256
+ (base32 "0manxn1ly5n8nqamv47hz7akxi6v0rzwc9j1c3x99vngrjlr5qw2"))))
(build-system gnu-build-system)
+ (native-inputs
+ ;; The 3.5.28 release tarball isn't bootstrapped.
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
(inputs
`(("libjpeg-turbo" ,libjpeg-turbo)
- ("libtiff" ,libtiff)))
+ ("libtiff" ,libtiff)
+ ("zlib" ,zlib)))
(arguments
- `(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'reproducible
- (lambda _
- ;; Ensure there are no timestamps in .svgz files.
- (substitute* "desktopfiles/Makefile.in"
- (("gzip") "gzip -n"))
- #t)))))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'bootstrap 'make-reproducible
+ (lambda _
+ ;; Ensure there are no timestamps in .svgz files.
+ (substitute* "desktopfiles/Makefile.am"
+ (("gzip") "gzip -n"))
+ #t)))))
(home-page "http://djvu.sourceforge.net/")
(synopsis "Implementation of DjVu, the document format")
(description "DjVuLibre is an implementation of DjVu,